Câu hỏi Cách dừng chuyển hướng tự động từ “http: //” sang “https: //” trong Chrome


Tôi đã có một cái gì đó thiết lập wacky trong thiết lập DNS của chúng tôi mà bây giờ đã được giải quyết.

Vấn đề còn lại là chrome đã lưu trữ các thiết lập không chính xác.

Cụ thể, khi sử dụng Chrome http://3rdrevolution.com hiện đang chuyển hướng đến https://3rdrevolution.com (tên miền rỗng), không hợp lệ / được hỗ trợ. http://3rdrevolution.com  NÊN chuyển hướng đến http://www.3rdrevolution.com và sau đó bắt buộc https://www.3rdrevolution.com.

Nhưng trên một số ít các trình duyệt (bao gồm cả của tôi) điều này không xảy ra vì một số bộ nhớ đệm Chrome sôi nổi. Tôi đã thử đi đến "Privacy -> Clear Cache" nhưng nó không có hiệu lực.


247
2018-03-13 17:40


gốc


kiểm tra các plugin của bạn (như SSL ở khắp mọi nơi), bạn đã thử xóa (shift + del) chưa? Thử sử dụng google.com/ncr thay vì google.xx. - malakrsnaslava
có thể trùng lặp Làm thế nào tôi có thể làm cho Chrome ngừng lưu trữ chuyển hướng bộ nhớ cache? - Ulrich Schwarz


Các câu trả lời:


Anon là đúng về STS, nhưng có một cách để xóa cụ thể miền của bạn khỏi tập hợp. Truy cập chrome: // net-internals / # hsts. Đi vào 3rdrevolution.com Dưới Xóa chính sách bảo mật miền và nhấn nút Xóa.


373
2018-02-23 14:17



Cảm ơn bạn, tôi đã thử mọi thứ khác và điều này cuối cùng đã làm việc =) - Tyrsius
Điều này đã giúp tôi! Trong khi phát triển nội bộ và có cùng một vấn đề của chuyển hướng! - Marcello de Sales
Người đàn ông, điều này đã làm tôi thất vọng về tuổi tác, cuối cùng cũng có nó, cảm ơn! Lưu ý tiềm năng của lưu ý: Nếu miền bạn đang gặp sự cố là miền phụ, bạn có thể cần phải xóa miền chính khỏi bộ HSTS nếu "bao gồm tên miền phụ cho STS được đặt thành true". Nếu bạn chạy một truy vấn trên tên miền mẹ, bạn sẽ thấy nếu nó được đặt hay không cho tên miền được đề cập. - Pooch
Điều này chỉ làm việc cho tôi sau khi tôi cũng xóa bộ nhớ cache của trình duyệt. Trong chrome: Cài đặt> Hiển thị cài đặt nâng cao…> Bảo mật> Xóa dữ liệu duyệt web ...  Nguồn - nittyjee
Kể từ 63.0.3239.132 này không có gì. Quy tắc này dường như bị bỏ qua và thậm chí các miền tùy chỉnh liên kết đến localhost hiện được chuyển hướng đến https. Yếu tố gây phiền nhiễu phải sử dụng chứng chỉ tự ký cho mọi thứ ... - Daniel


Vấn đề của tôi đến từ việc có một .dev tên miền, gần đây đã được đăng ký là gTLD và cam kết sử dụng Chrome Canary. Tôi tìm thấy điều này từ một bài đăng gần đây Tôi bắt gặp khi tôi tìm kiếm vấn đề của mình.

Nếu bạn có cùng một vấn đề tôi làm, có vẻ như giải pháp tốt nhất là thay đổi tên miền của bạn thành một thứ khác với .dev. Bài viết được đề xuất .test với một giải pháp tiềm năng của .localhost sau đó xuống đường (qua đề xuất này).


161
2017-09-18 16:21



Đây cũng là vấn đề đối với tôi. Trên máy phát triển địa phương của tôi, tôi đã sử dụng .dev trong gần 10 năm nay. Tôi đã cập nhật Google Chrome gần đây và nó đã bắt đầu chuyển hướng tất cả các trang web của tôi tới https mà không có lý do gì tôi có thể hiểu được. Đã không bao giờ nghĩ rằng nó đã làm với .dev, sau đó tôi đi qua câu trả lời này và thay đổi nó để .development và tất cả các hoạt động tốt một lần nữa ... Bây giờ :-). Cảm ơn một lần nữa! - conrad10781
Hoàn hảo! Tôi không hiểu tại sao Chrome lại làm như thế, nó rất khó chịu vì tôi có gần 30 tên miền .dev ở địa phương của mình. Hy vọng đó là một lý do rất, rất tốt. - Pablo Ezequiel Leone
Tôi đã cài đặt wordpress, thay đổi tên miền của nó có thể là một nhức đầu thực sự. tương tự cho tên thư mục chính ect. có cách nào khác xung quanh không? - Rick Sanchez
Đó là vì Google đã mua .dev và có lẽ sẽ bắt đầu làm cho các trang web công cộng sử dụng nó. - Hilton Shumway
FML ... Tôi gần như đã từ bỏ sự nghiệp trên web 10 năm của mình vì điều này. #starbucksbarista - elbowlobstercowstand


https://www.3rdrevolution.com gửi Nghiêm ngặt-Giao Thông Vận Tải-An Ninh tiêu đề để truy cập nó qua https một lần sẽ làm cho các trình duyệt như Chrome / Firefox chuyển hướng các yêu cầu http đến https cho đến khi một số điểm được chỉ định trong tương lai.

Như câu trả lời khác cho biết, cách duy nhất để ngăn chặn điều này một khi nó bắt đầu là để xóa bộ nhớ cache của trình duyệt (hoặc chờ cho trình duyệt hết hạn thứ tự).


15
2017-10-19 19:58





Đến xóa tên miền trong menu "HSTS" trong chrome: // net-internals là một giải pháp tạm thời. Sau khi truy cập miền này qua HTTPS, nó sẽ được đưa vào danh sách HSTS lần nữa.

Về cơ bản, để giải quyết vấn đề này, cần phải vô hiệu hóa bảo mật giao thông HTTP nghiêm ngặt trên máy chủ web 3rdrevolution.com (IIS, Apache, nginx, ...). Đối với nginx, hãy chỉnh sửa phần HTTPS của nó trong nginx.conf và đặt 'max-age = 0' cho Nghiêm ngặt giao thông-bảo mật:

server {
#...
        ssl on;
#...
        add_header Strict-Transport-Security "max-age=0;";
#...
}

Thêm thông tin:Bảo mật truyền tải nghiêm ngặt HTTP (HSTS)


12
2017-07-05 17:47



Tôi không thể làm cho phương thức add_header hoạt động. - Alex Barker
đối với tôi máy chủ không phát hành tiêu đề HSTS vì vậy đây không phải là giải pháp. Từ những gì tôi có thể nói, chrome được ghi lại khi tôi vô tình truy cập nó bằng https và tạo một bản ghi HSTS nội bộ sau đó chuyển hướng tôi một cách bí ẩn đến https mọi lúc. Khắc phục là sử dụng bản ghi xóa HSTS trong chrome: net-internals. Đã có một người kiểm tra tiện dụng trong đó là tốt. - rob
Để xóa bản ghi HSTS là một giải pháp tạm thời. Bạn sẽ nhận được bản ghi này trong chrome một lần nữa và một lần nữa sau khi truy cập https cho đến khi máy chủ gửi "max-age = 0". - user2285323


Có thể có một vài lý do cho việc này, bao gồm cả plugin nhưng giả sử rằng bạn không có bất kỳ plugin nào được cài đặt, bạn có thể thực hiện các thao tác sau:

Đi đến Cài đặt / Bảo mật / Xóa dữ liệu duyệt web ...

Lựa chọn Bắt đầu của thời gian trong kéo xuống.

Lựa chọn:

  • Xóa dữ liệu biểu mẫu Tự động điền đã lưu
  • Xóa cookie và dữ liệu trang web và plugin khác
  • Làm sạch bộ nhớ tạm

Lựa chọn Xóa dữ liệu truy cập

Điều này sẽ giúp bạn thực hiện bất kỳ thao tác Tự động điền nào dựa trên lần duyệt trước của bạn. Ngoài ra, nó sẽ loại bỏ bất kỳ cookie nào cũng có thể gây ra sự cố.


9
2018-05-08 16:57



Vấn đề đối với tôi là cache. Tôi đã có thể vào trang web của tôi tốt trong firefox và một cửa sổ ẩn danh chrome. Không có cookie nào cho trang web. - ton.yeung
Điều này cũng làm việc cho tôi nơi HSTS không. Tôi chỉ phải kiểm tra hộp kiểm "Hình ảnh và tệp". - dgig
Điều này làm việc cho tôi, trong khi HSTS và các giải pháp khác thì không. - AllisonC


Một lựa chọn ít quyết liệt hơn là xóa tất cả cookie bao giờ hết Cài đặt> Hiển thị cài đặt nâng cao> Cài đặt nội dung> Tất cả cookie và dữ liệu trang web sau đó tìm kiếm các trang web được đề cập và xóa cookie chỉ cho các trang web đó.


4
2018-04-01 13:19



Cảm ơn điều này hoạt động hoàn hảo. Tôi không biết tại sao Chrome lại tạo ra một tính năng ẩn như vậy ..... thực ra, tôi có thể đoán tại sao ... - ktec
điều này dường như không hoạt động với phiên bản Chrome hiện tại. - Vylix


Nếu bạn đang đối mặt với vấn đề trên một tên miền phụ thì dòng này trong Nginx có thể gây ra vấn đề ngay cả khi tên miền phụ nằm trong một máy chủ khác, vì trình duyệt sẽ lưu trữ thông tin này.

add_header Strict-Transport-Security "max-age=31536000; includeSubdomains;";

để loại bỏ includeSubdomains; của nó để làm cho nó hoạt động.


2
2017-07-25 14:26





Trước một vài ngày, tôi vô tình bật tùy chọn Chrome có tên:

  • Tự động gửi một số thông tin hệ thống và nội dung trang cho Google để giúp phát hiện các ứng dụng và trang web nguy hiểm
  • Bảo vệ bạn và thiết bị của bạn khỏi các trang web nguy hiểm

Và bây giờ vấn đề chính là trang web của chúng tôi trên tên miền phụ luôn chuyển hướng từ http: // đến https: // và trình duyệt đã cho tôi lỗi:

"Kết nối của bạn không phải là riêng tư. Những kẻ tấn công có thể đang cố lấy cắp thông tin của bạn từ censored.censored.com (ví dụ: mật khẩu, tin nhắn hoặc thẻ tín dụng). NET :: ERR_CERT_COMMON_NAME_INVALID"

Mở chrome: // settings / privacy và bật các tùy chọn chrome được đặt tên trước đây tự động bảo vệ thiết bị của bạn. Hy vọng điều này sẽ giúp một ai đó.


2
2018-02-27 19:33



Dường như không làm việc cho tôi. - Dave Burton


Từ https://galaxyinternet.us/google-chrome-redirects-localhost-to-https-fix/

Không có bản sửa lỗi tùy chọn nào phù hợp với tôi, để sửa lỗi https://localhost:3000, điều này đã làm.

Bấm và giữ nút tải lại và chọn "Empty Cache và Hard Reload", điều này dường như chỉ là một tùy chọn trên localhost.

Screenshot of the “Empty Cache and Hard Reload” option.


2
2018-05-30 03:53





trong Chrome 66, rất nhiều thay đổi trong Settings chuyển hướng

bạn có thể đi đến chrome://settings/resetProfileSettings?origin=userclick sau đó nhấn đặt lại.

điều này làm việc cho tôi.


1