Câu hỏi HuBot với HipChat: kết nối, nghe nhưng không nói


Tôi cố gắng cấu hình HuBot để làm việc với HipChat. HuBot của tôi dường như đang kết nối và nghe chính xác, tuy nhiên không phản hồi bất cứ điều gì. Tôi sẽ đánh giá cao bất kỳ suy nghĩ về những gì vấn đề có thể được, hoặc làm thế nào để đi về gỡ lỗi vấn đề bản thân mình.

Tôi đã thiết lập bot như thế nào

Ban đầu, tôi đã làm theo hướng dẫn để cài đặt Hubot bằng Bộ điều hợp HipChat lên Heroku. Tuy nhiên, bot không trả lời.

Vì đây là lần đầu tiên tôi sử dụng Heroku, sau đó tôi chuyển sang chạy bot từ máy chủ Ubuntu 12.04, để tôi có thể dễ dàng nhìn thấy những gì đang diễn ra. Vì điều này, tôi lấy cảm hứng từ Hướng dẫn triển khai UNIX cho HuBot

Vì vậy, bây giờ tôi có bot chạy trên Ubuntu, được kích hoạt từ dòng lệnh.

Đọc nhật ký

Các bản ghi HuBot hiển thị:

  1. Rằng bot kết nối với HipChat thành công. Ngoài ra, tôi có thể thấy bot được kết nối từ máy khách HipChat trên máy tính để bàn của tôi
  2. Bot đã kết nối với đúng người dùng và đang nghe đúng tên.
  3. Rằng bot nhận được tin nhắn từ HipChat. Nếu tôi nhập một tin nhắn từ một tài khoản khác vào máy khách HipChat, nó sẽ xuất hiện trong nhật ký của bot.
  4. Không có lỗi xuất hiện trong nhật ký

Tuy nhiên sau khi một tin nhắn đã được nhận bởi Hubot, nó không bao giờ gửi bất cứ điều gì ra ngoài. Ngoại trừ một thông báo trống cứ 30 giây một lần (tôi giả sử điều này là giữ kết nối với HipChat còn sống):

[Thu Jun 20 2013 18:55:11 GMT+0100 (BST)] DEBUG  OUT > 

Tôi không thể tìm thấy bất kỳ hướng dẫn xử lý sự cố cho HuBot hoặc làm việc ra bản thân mình như thế nào để gỡ lỗi vấn đề.


2
2018-06-20 18:08


gốc




Các câu trả lời:


Khi tôi gặp phải vấn đề này, khi tôi chỉ định HUBOT_HIPCHAT_HOST. Việc xóa cài đặt đó đã làm cho nó hoạt động trở lại (có vẻ như đang chọn một JID không chính xác trên thư trả lời).

Cập nhật: Sự cố này đã được giải quyết https://github.com/hipchat/hubot-hipchat/issues/160


3
2018-02-11 19:28